Microsoft JScript runtime error: AjaxControlToolkit requires ASP.NET Ajax 4.0 scripts.

Hoje fazendo a migração do VS2005 para o Visual Studio 2010, parei nesse erro:

“Microsoft JScript runtime error: AjaxControlToolkit requires ASP.NET Ajax 4.0 scripts. Ensure the correct version of the scripts are referenced. If you are using an ASP.NET ScriptManager, switch to the AjaxScriptManager in System.Web.Ajax.dll, or use the ToolkitScriptManager in AjaxControlToolkit.dll.”

Agora é obrigatório usar o ToolkitScriptManager ao invés do ScriptManager quando se está utilizando o control tool kit. Para eliminar esse problema é só substituir um pelo outro e tudo volta a funcionar.

Por exemplo…

Registre o assemby do ControlToolKit
<%@ Register    Assembly=”AjaxControlToolkit”    Namespace=”AjaxControlToolkit”    TagPrefix=”controltoolkit” %>

Então substitua o asp:ScriptManager por:

<controltoolkit:ToolkitScriptManager
ID=”ScriptManagerMain”            runat=”server”>
</controltoolkit:ToolkitScriptManager>

Deixe uma resposta

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s